next up previous 98
Next: FURTHER CONFIGURATION
Up: Xoracdr
Previous: USING XORACDR


THE MAIN WINDOW

The Xoracdr main window is divided into three main sections. At the top is the menu bar with File, Display, Options, Recipe and Help menus.

Figure: The Xoracdr main window
\includegraphics[width=5.0in]{sun230_xoracdr.eps}

File Menu
Stop Processing

When the pipeline is running further data processing can be halted by selecting this menu entry. Control will be returned to the main window, processing can be restarted from the beginning by depressing the Start ORAC-DR button.

Pause Processing

When the pipeline is running the processing of further data can be paused by selecting this menu item, a pop-up window will appear with a Resume button. Processing can be re-started by depressing the Resume button in the pop-up.

Nuke ORAC-DR

Selecting this menu option will kill all ORAC-DR related processes, including spawned Starlink monoliths, and will free up any shared memory used by these processes. This will also kill the Xoracdr graphical user interface.

Display Menu
No Display

Selecting this checkbox will instruct Xoracdr not to launch the display system. No data will be displayed and GWM (or GAIA) windows will not be launched.

Configure Display

Allows configuration of the ORAC-DR display environment. Selecting this menu item will display a popup window which can be used to edit the current environment and add display directives to the current environment. This popup can also be run as a stand alone application from the command line, e.g.

  % oracdisp

for more information on how to use the display environment editor see the oracdisp documentation and the documentation on the DisplaySystem.

Options Menu
Allow Resume

Allow the pipeline to resume midway through the processing of a group so long as the recipe/instrument supports this behaviour. Default is for the group file to be deleted when a new group is created. When this menu option is selected, the group file is retained. NOTE this option is not currently supported by IRCAM, UFTI and SCUBA recipes.

No Engines

Do not start algorithm engines. NOTE this will cause the vast majority of recipes to fail.

Common ADAM

Do not create an invocation specific temporary directory for the messaging systems but use whatever directory is the usual default. For ADAM tasks this would mean that ~/adam or $ADAM_USER will be used rather than a private ORAC-DR directory. This should only be used when it is required for ORAC-DR to talk to tasks that were not started by the pipeline and could lead to possible confusion if multiple pipelines are running using this flag.

Verbose

If selected then messages from the Starlink engines will be printed in addition to the normal ORAC-DR messages

Debug

Log debug messages to file ORACDR.DEBUG in $ORAC_DATA_OUT.

Warn

Turn on perl level warning messages (perl -w). This should be used for debugging only. If -verbose is also true then full perl diagnostics are turned on (see diagnostics for more information on this perl pragma).

Beep

Is selected the pipeline will make as much noise as possible over errors and pipeline exit.

Setup Environment

If selected a window will appear allowing you to enter file paths for the data and calibration root directories, user recipe and primitive directories, the raw and reduced data directories and the instrument calibration directory. If these have already been set, either by selecting an instrument from the listbox or from environment variables you can override the default options using this popup window. NOTE The raw and reduced data paths will be overridden if you select an instrument from the main window listbox after entering values into this window.

Calibration Options

This item will remain disabled until an instrument is selected in the main window listbox, after this you are free to select this item from the menu. On selection a window will popup allowing you to enter calibration options for the instrument, see the user guide for your instrument for more information.

Recipe Menu
Show Current Recipe

Selecting this menu item will ensure that the recipe display window will appear along with the log window. The recipe display window will show the currently executing recipe and a list of the primitives contained in the recipe. The currently running primitive will be highlighted.

Override: RECIPE

This item will be greyed out until an override recipe is selected using the Override Recipe option further down the Recipe menu. After an override recipe is selected then this option will become active. If the checkbox is selected then the selected recipe will override the one specified in the file headers. This override recipe is used for all data files regardless of header contents or observation mode, so make sure you only only apply it to appropriate data frames.

Set Override Recipe

This item will remain disabled until an instrument is selected in the main window listbox, after which if selected it will allow you to choose an Override Recipe

Edit Recipe

Allows you to select and then edit a recipe. The recipe will be saved to ORAC_RECIPE_DIR, the user recipe directory, which if unset will default to ORAC_DATA_OUT. Recipes in ORAC_RECIPE_DIR will be run in preference to those in the instrument recipe directories of the same name.

Help Menu

Selecting an entry from the Help menu will popup a help browser to display the relevant documentation. At the bottom on the menu there is also an About XORAC-DR entry which will display the licence terms and conditions for the ORAC-DR software.

At the bottom of the main window is the status bar, this reports the status of the pipeline process. It will display the currently running recipe name, along with other status information.

Between the menu and status bar is the bulk of the main window. On the left is the instrument list box, this allows you to select the instrument whose data you wish to process. If the ORAC_INSTRUMENT environment variable is set before starting Xoracdr the instrument will be preselected on startup.

Once an instrument is selected the user interface will be configured into a default state for the instrument. NOTE it is important to select an instrument before doing any customization of the settings as your changes may be overridden by the default options imposed by setting up an instrument.

At this point the Start ORAC-DR button will become enabled and you can start the pipeline if the configuration options are to your liking.


next up previous 98
Next: FURTHER CONFIGURATION
Up: Xoracdr
Previous: USING XORACDR

ORAC-DR: Overview and General Introduction
Starlink User Note 230
Frossie Economou, Tim Jenness,
Malcolm Currie, Andy Adamson, Alasdair Allan, Brad Cavanagh
Joint Astronomy Centre, Hilo, Hawaii
June 2004
E-mail:starlink@jiscmail.ac.uk

Copyright © 1997-2004 Particle Physics and Astronomy Research Council